การใช้ VRF นั้นเหมือนกับการใช้เราเตอร์แยกต่างหาก หากคุณมี WAN IP เดียวกันสำหรับ VRF ทั้งสองคุณต้องกำหนดค่าสองครั้งในทั้งสองอินเตอร์เฟส WAN อย่างไรก็ตามหากคุณใช้เพียงหนึ่งอินเตอร์เฟส WAN คุณจะต้องแบ่งอินเทอร์เฟซนี้โดยการ trunking (โดยใช้ VLAN) หรืออินเทอร์เฟซย่อย
อดีต:
interface FastEthernet0.5
encapsulation dot1Q 5
ip address 1.1.1.1 255.255.255.252
แจ้งให้ทราบว่าเราไม่ได้ใช้การส่งต่อ ip vrf เรากำลังใช้ vrf เริ่มต้นที่นี่
interface FastEthernet0.10
ip vrf forwarding wanconnection:1
encapsulation dot1Q 10
ip address 1.1.1.1 255.255.255.252 (<== this can be another IP if you prefer to divide it with 2 different IP's)
การเชื่อมต่อจะเป็นดังนี้:
- เราเตอร์ของคุณ (ปกติ vrf) => การเชื่อมต่อ wan => vpn ใช้สำหรับแท็ก dot1Q 5
- เราเตอร์ของคุณ (wanconnection: 1 vrf) => wan connection => vpn ใช้สำหรับแท็ก dot1Q 10
หากคุณต้องการทำสิ่งนี้โดยไม่ต้องติดแท็กและมีอินเทอร์เฟซทางกายภาพ 2 ตัวมันเป็นการใช้งานแบบเดียวกัน:
interface FastEthernet0
ip address 1.1.1.1 255.255.255.252
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 1.1.1.1 255.255.255.252
อินเทอร์เฟซอื่น ๆ ทั้งหมดที่จำเป็นใน vrf "wanconnection: 1" ที่เฉพาะเจาะจงจะต้องเพิ่มในลักษณะเดียวกัน:
ip vrf forwarding wanconnection:1
อดีต:
interface FastEthernet4
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
การสร้าง vrf: http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/15.02SG/configuration/guide/vrf.html
ip vrf wanconnection:1
rd 65000:1
คำสั่ง rd 100: 1 อธิบาย: สร้างตาราง VRF โดยการระบุตัวกระจายเส้นทาง ป้อนหมายเลข AS และหมายเลขโดยพลการ (xxx: y) หรือที่อยู่ IP และหมายเลขโดยพลการ (ABCD: y)
สำหรับส่วนเส้นทาง:
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 1.1.1.2
หากคุณมีการเชื่อมต่อ WAN หนึ่งครั้งโดยไม่เปิดใช้งานการติดแท็กคุณสามารถใช้การกำหนดเส้นทางระหว่าง Vrf: http://packetlife.net/blog/2010/mar/29/inter-vrf-routing-vrf-lite/
อดีต:
ip vrf wanconnection:1
rd 65000:1
route-target export 65000:2
route-target import 65000:99
ip vrf wanconnection:2
rd 65000:2
route-target export 65000:1
route-target import 65000:99
ip vrf shared:1
rd 65000:99
route-target export 65000:99
route-target import 65000:1
route-target import 65000:2
interface FastEthernet0
ip vrf forwarding shared:1
ip address 1.1.1.1 255.255.255.252
interface loopback1
ip vrf forwarding shared:1
ip address 2.2.2.2 255.255.255.255
ip route vrf shared:1 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 2.2.2.2
ip route vrf wanconnection:2 0.0.0.0 0.0.0.0 2.2.2.2
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
description "LAN interface vrf 1"
interface FastEthernet2
ip vrf forwarding wanconnection:2
ip address 10.0.2.1 255.255.255.0
description "LAN interface vrf 2"
ที่นี่ FastEthernet1 จะใช้เส้นทางเริ่มต้นสำหรับ vrf wanconnection: 1 และ FastEthernet2 จะใช้เส้นทางเริ่มต้นสำหรับ vrf wanconnection: 2 (จัดทำโดยคำสั่ง "เส้นทาง IP")