การกำหนดค่า OpenVSwitch บน dumb AP ที่กำลังรัน openwrt


0

ฉันกำลังพยายามเรียกใช้ openvswitch บน OpenWrt นี่คือการตั้งค่าที่ฉันพยายามทำ: ฉันมีไคลเอนต์ไร้สาย 2 ตัวเชื่อมต่อกับ AP ที่กำลังใช้งาน OpenWRT (จุดเชื่อมต่อของฉันคือ Netgear WNDR3700) AP เป็นใบ้ จากนั้นฉันก็เชื่อมต่อ AP กับ PI PI เชื่อมต่อกับอินเทอร์เน็ตและกำลังเรียกใช้ DHCP ในที่สุดฉันก็มี Onos วิ่งบน PI

Onos สามารถเห็นอุปกรณ์ (สวิตช์ ovs) และยังสามารถเห็นโฮสต์ (แล็ปท็อปสองเครื่อง) แต่โฮสต์จะไม่ได้รับที่อยู่ IP ใด ๆ เมื่ออินเตอร์เฟสไร้สายถูกกำหนดให้กับเครือข่าย LAN พวกเขาจะถูกกำหนดที่อยู่ IP แต่ onos ล้มเหลวในการดูโฮสต์

============

นี่คือการปรับปรุงบางอย่าง ฉันสร้างอินเตอร์เฟส wan eth1.1 และเพิ่มลงใน ovs bridge ฉันเพิ่มกฎใน ovs เพื่อส่งแพ็กเก็ตใด ๆ ที่เข้ามาที่พอร์ต 2 (wlan0) ไปยังพอร์ต 3 (eth1.1) PI เชื่อมต่อกับพอร์ต WAN ของเราเตอร์ ฉันทำ tcpdump บน ovs bridge, อินเตอร์เฟส wlan0 และอินเตอร์เฟส eth1.1 ฉันสามารถเห็นแพ็คเก็ต arp ที่มาจากไคลเอนต์ไร้สายในทั้ง 3 อินเตอร์เฟส ... แต่เมื่อฉันทำ TCPdump บน eth1 ของ pi ฉันไม่เห็นอะไรเลย

============

นี่คือ/etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd3c:8eef:8a02::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1 eth1 radio0.network1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.43.2'
    option gateway '192.168.43.1'
    option dns '192.168.43.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config interface 'wlan0'
    option proto 'none'

และนี่คือ / etc / config / wireless

config wifi-device 'radio0'    
    option type 'mac80211'    
    option channel '11'  
    option hwmode '11g'
    option path 'pci0000:00/0000:00:11.0'
    option htmode 'HT20'

config wifi-iface
    option device 'radio0'
    #option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

คำตอบ:


0

[แก้ไขแล้ว] นี่คือการเปลี่ยนแปลงใน / etc / config / network

[Solved] here is the change in the /etc/config/network file: 
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd3c:8eef:8a02::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1 eth1 ovsbr'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.43.2'
    option gateway '192.168.43.1'
    option dns '192.168.43.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'
    option enable_vlan4k '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config interface 'wan'
    option ifname 'eth1.1'
    #option force_link '1'
    option proto 'none'
    #option ipaddr '192.168.43.4'
    #option netmark '255.255.255.0'


config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '3'
    option ports '3 5t'

config interface 'lan1'
    option proto 'static'
    option ifname 'eth0.3'
    #option auto '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'
    option ports '2 5t'

config interface 'lan2'
    option proto 'static'
    option ifname 'eth0.2'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '4'
    option ports '1 5t'

config interface 'lan3'
    option proto 'static'
    option ifname 'eth0.4'

config switch_vlan
    option device 'switch0'
    option vlan '5'
    option vid '5'
    option ports '0 5t'

config interface 'lan4'
    option proto 'static'
    option ifname 'eth0.5'

#config interface 'ovsbr'
#   option proto 'static'
#   option ifname 'ovsbr'
#   option ipaddr '192.168.43.3'
#   option netmask '255.255.255.0'
#   option type 'bridge'

config interface 'wlan0'
    option protocol 'none'

โปรดทราบว่าฉันเพิ่ม eth1.1, eth0.2, eth0.3, eth0.4 และ eth0.5, wlan0 เป็นพอร์ตไปยังสะพาน ovsbr! :)

โดยการใช้ไซต์ของเรา หมายความว่าคุณได้อ่านและทำความเข้าใจนโยบายคุกกี้และนโยบายความเป็นส่วนตัวของเราแล้ว
Licensed under cc by-sa 3.0 with attribution required.